N
BUILDING BETTER SPREADSHEETS

How To Build Better Lists with Spreadsheets

Spreadsheets are a powerful tool that can be used for a variety of
tasks, from tracking finances to managing projects. However, if
they are not built correctly, they can be a source of frustration
and errors. This presentation will discuss some tips for building
better spreadsheets.

* Patrick Arehart - Centerville Noon Optimist Club, since 2017 ——
. Ohio District Webmaster 2022-2024 =
* pra@arehart.com 937-681-1902

* Database de*ner and programmer since 19794 "



mailto:pra@arehart.com

OVERVIEW

* We are going to build a spreadsheet.
Later I’ll show you some templates, but
| want you to understand the basics.

» After the spreadsheet | will explain
many considerations and “Rules” to
help with new and existing
spreadsheets.




= f | NEW SPREADSHEET — COLUMN HEADINGS

STEP 1

Open Excel > File > New > Blank workbook

@ Home v NEW

DNEW

=7 Open

Info

Blank workbook

Save



NEW SPREADSHEET — COLUMN HEADINGS

STEP 2

In Row 1, add headings Date, Item, Price, and Notes

Price Notes




NEW SPREADSHEET — COLUMN HEADINGS

STEP 3

Add today’s date to row 2.




STEP 4

On “View'" tab, Window Section, click “Freeze Panes”
> "Freeze Top Row”

View Automate Developer Add-ins Help Inquire | iH Comments |
| AN | i ' = ——
Formula Bar Q 100 :-C)\ Ij New Window E i k) (% EEQ
Zoom 100% Zoom to E AR i [DI SWEh M:crns
Gridlines Headings . . .
Selection m‘ﬂ P e ] ] | iy | Windows v v
Show Zoom

o Freeze Panes

F Keep rows and columns visible while the rest of
the worksheet scrolls (based on current selection).

o5 Freeze Top Row

| Keep the top row visible while scrolling through
the rest of the worksheet.
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NEW SPREADSHEET: FORMATITING
COLUMN HEADINGS — STEP 1

Click Date Heading, Home > Alignment Section > Align Right

= = = B~ EEJ Wrap Text

= = ? £= 3= H MErgE B Center Date Item Price Notes
— 4/29/2023 4.9
I Alignment [
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""" NEW SPREADSHEET: FORMATTING COLUMN
HEADINGS — STEP 2

Highlight the “Date” column by clicking the “A" column. Then

go fo Home > Number and change the “General” dropdown
to “Short Date”

ﬂ ]| H
(L General
123 No specific format
- \General ~| Jaiste
Currency
6~ % 9B 9% -8

l; Accounting

Short Date

Mumber [

7 Long Date




NEW SPREADSHEET: FORMATIING COLUMN
HEADINGS - STEP 3

Highlight the “Price” column by clicking the “C" column and
then go tfo Home > Number and change the "General”
dropdown to "Number”

3 |
- ‘Eeneral v‘ T Gemeral

123 No specific format
.0 .00 Number
$ > % 5 f.rl:ll:l —=0 12 Item Price Notes

5 Currency
Mumber [ @

4/29/2023 4.90




Highlight row 1 by clicking the “1" row

NEW SPREADSHEET: FORMATIING COLUMN
HEADINGS - STEP 4

File Home |Insert Pagelayout Formulas Data Review

“) - El'j Calibri vi11 v
G Paste[EIv|‘IUVAA

S Hegv A

Undo Clipboard = Font ~
Al v | X  Jx|| Date
A | B C

—

Date Item Price
4/29/2023

1
2
3
4

=8 =

= fl’%l

D
Notes
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'NEW SPREADSHEET: FORMATTING COLUMN
HEADINGS - STEP &

In Home > Font click “B" icon to bold your headings. Can also
use Ctrl + B
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= "~ NEW SPREADSHEET: FORMATTING COLUMN

HEADINGS - STEP 6

In Home > Font click “B" icon to bold your headings. Can also
use Ctrl + B

A B C D E
—_— . : Price
= = |§| P~ EEJ Wrap Text |_ Increase
— : in 2023
= = |£| = = | Merge & Center ~ 1 Date Item Price Notes Year
_ Pl 4/29/2023 4.90
Alignment [ 3



1
2
3
4
5
6
7
8
9
10
11

A
Credit
Card
Date Used
4/6/2023 Chase
4/3/2023 Chase
4/3/2023 Chase
4/3/2023 n/a
4/3/2023 Fidelity
4/2/2023 Chase
4/2/2023 Chase
3/23/2023 Fidelity
3/23/2023 Fidelity
3/27/2023 Chase

Purchased

From Qty
Amazon 16
Amazon 1
Amazon 3
AWT 1
Zix 1
Amazon 1
Amazon 1
Ebay 1
Checksforle 1
Amazon 1

Dollars Extended
79.98 1279.68
89.90 89.90
79.98 239.94

1200.00 1200.00

106.68 106.68
29.97 29.97

468.99 468.99
64.50 64.50

185.69 185.69
99.99 99.99

Shipped Description

AWT
AWT
AWT
OPI
OPI
AWT
AWT
OPI
OPI
OPI

2TB Crucial NVME PCIE 4.0 drives
Mid-Tower Case Pure Base 600 Silver
2TB Crucial NVME PCIE 4.0 drives

PC for OPITest

Office Charges

Video Camera Stand

Motherboard and CPU

Brother Laster Printer Toner

1000 checks and 500 envelopes

6 TB drive for OPI, for Test PC.




Credit
Card
Date Used

12/7/2022 Chase
12/5/2022 Chase
7/16/2022 Chase
7/16/2022 Chase
7/16/2022 Chase
7/13/2022 Chase
7/13/2022 Chase
7/13/2022 Fidelity
7/11/2022 Chase
7/8/2022 Chase
6/17/2022 Chase
6/17/2022 Chase
6/16/2022 Chase
6/15/2022 chase
6/13/2022 Chase
6/13/2022 Chase
6/11/2022 Chase
6/9/2022 Chase
6/7/2022 Chase
6/7/2022 Chase
6/7/2022 Chase

Purchased
From Qty
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
AppRiver
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon

1
1
1
1
1
1
1
2
1
1
1
1
4
1
1
1
1
1
1
1
1

Amazon

Dollars Extended
41.28 41.28
53.19 53.19
98.35 98.35
42,12 42.12

212.12 212.12
98.15 98.15
26.59 26.59
69.42 138.84
41.85 41.85
56.14 96.14
25.79 25.79
42.99 42.99

7.46 29.84
15.99 15.99

693.96 693.96
50.50 50.50

129.85 129.85
62.00 62.00

480.00 480.00

4,89 4.89
65.00 65.00

FREEZE TOP ROW EXAMPLE

Shipped Description

ACLLC
ACLLC
OPI
ACLLC
ACLLC
ACLLC
ACLLC
OPI
ACLLC
ACLLC
ACLLC
ACLLC
ACLLC
OPI
OPI
ACLLC
OPI
OPI
OPI
OPI
OPI

Westinghouse Lighting
1/4-20 Hex Button He
Fiber optic tester

10 pack 1.5 ft patch ca
Mouse, AirTags, Label
Power Wire Loom, NP
Ratchet Screwdriver, (
Office 365

Hubbell Raco Retro-B
40ft high-speed 8K H[J
Replacement UPS batt
Monoprice 12/24 Scre
GBIC for Netgear

4 hard drives, eSATA
Home Automation Te
x2, Fantom 4TB eSATA
4 SAS drives for serve
UPS for OPI 1500 VA, ¢
x5, 10ft nema cords

2 SAS drives for serve
Home Automation Te

12/7/2022 Chase
12/5/2022 Chase
7/16/2022 Chase
7/16/2022 Chase
7/16/2022 Chase
7/13/2022 Chase
7/13/2022 Chase
7/13/2022 Fidelity
7/11/2022 Chase
7/8/2022 Chase
6/17/2022 Chase
6/17/2022 Chase
6/16/2022 Chase
6/15/2022 chase
6/13/2022 Chase
6/13/2022 Chase
6/11/2022 Chase
6/9/2022 Chase
6/7/2022 Chase
6/7/2022 Chase
6/7/2022 Chase
6/1/2022 Chase
6/1/2022 Chase

Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
AppRiver
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon
Amazon

BN R R R R R R R R R R R RENR R R R R R

Westinghouse Lightin
1/4-20 Hex Button Hel
Fiber optic tester

10 pack 1.5 ft patch c4
Mouse, AirTags, Labe
Power Wire Loom, NH
Ratchet Screwdriver, {
Office 365

Hubbell Raco Retro-B
40ft high-speed 8K HL
Replacement UPS ba

Monoprice 12/24 Scrd
GBIC for Netgear

4 hard drives, eSATA

Home Automation Te
x2, Fantom 4TB eSAT/
4 SAS drives for serve
UPS for OPI 1500 VA,
x5, 10ft nema cords

2 SAS drives for serve
Home Automation Te
Thermaltake Toughpd
Corsair Vengence DD




Column headings go across the top of
the spreadsheet.

Only ONE ROW OF COLUMN HEADINGS!

RULES FOR LIST Do not skip columns and do not skip
BASED rOwWS.
SPREADSHEETS

Pick Excel first over Word. Very easy to
convert back to Word.

Do not use colors to convey information.
Create a new column and filter using it.




BENEFITS OF

LIVING BY
THE RULES

Sorting — One click away.

Filtering: Data > Sort and Filter > Filter Icon

Outline View - Visually see groups and sub-
groups of data: Data > Outline

Formatting: Home > Styles > Format as
Table)

Totals and Subtotals - like =SUM(D2:D4814),
use the “Sum Button”



ORDER OF COLUMNS MATTERS

e Put skinnier data on the left like Date, Manufacturer, Item#, Qty, and Price

e Put Wider data on the right, like descriptions and notes

e |f you put Description first it takes up too much space plus data will get cut off
e Format Dates as “Short Date”

e |[f you split the screen later the skinnier data identifies the row

e C D E F G H ) K L
Mfg

Manufactur Item
L Source er Number Item Number UPC Number Qty Price Extension Description Notes
2 Lowes Granger Ofc365 AWT Office 365 11000-31321 53.19 53.19 1/4-20 Hex Button Head Cap These are available
3 Amazon Gigabyte Ofc365 AWT Office 365 11000-31321 98.35 98.35 Fiber optic tester Important item. Be
4 Amazon Gigabyte Ofc365 AWT Office 365 11000-31321 42.12 42.12 10 pack 1.5 ft patch cables, 1 Good Buy. Used by
5 Amazon Gigabyte Ofc365 AWT Office 365 11000-31321 212.12 212,12 Mouse, AirTags, Label Tapes Much needed. Can
6 Amazon Gigabyte Ofc365 AWT Office 365 11000-31321 98.15 98.15 Power Wire Loom, NPOT Ad: Rarely used. But go
7 Amazon Gigabyte Ofc365 AWT Office 365 11000-31321 26.59 26.59 Ratchet Screwdriver, Compair Excellent value, get
Sl Microsoft Microlsoft Ofc365 AWT Office 365 11000-31321 69.42 138.84 Office 365 There are free alte
9 Amazon Gigabyte 0Ofc365 AWT Office 365 11000-31321 41.85 41.85 Hubbell Raco Retro-Brace,3 Needed for produc
10 Amazon Gigabyte Ofc365 AWT Office 365 11000-31321 96.14 96.14 40ft high-speed 8K HDMI Cal  Will work in storagg
11 Amazon Gigabyte Ofc365 AWT Office 365 11000-31321 25.79 25.79 Replacement UPS batteries. Durable batteries.
12 Amazon Gigabyte Ofc365 AWT Office 365 11000-31321 42.99 42,99 Monoprice 12/24 Screw for I Check other source

13 Amazon Gigabyte Ofc365 AWT Office 365 11000-31321 7.46 29.84 GBIC for Netgear Works well with Fi



SORTING AND FILTERING

By following the rules this is what we are looking forl!

Do two things first:

e Make a backup of your spreadsheet
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Do two things first:

e Make a backup of your spreadsheet S O RTl N G

e Add a Sequence column

b

Charge for Actively Entered
Date URL Available availibility PRA Rank DCA Rank in Use

3/2/2021 industrysitedesign TRUE 0.00 12000 900
2/26/2021 webdesigninc TRUE 500.00 8000 900
2/26/2021 websitemanufacturing TRUE 0.00 900
2/26/2021 websitemachinery TRUE 0.00 400

3/2/2021 industrywebsitedesign TRUE 0.00 900
2/26/2021 industrysites TRUE 4999.00 800
2/23/2021 technicalwebdesign TRUE 0.00 600
2/26/2021 webservice TRUE  250000.00 600
2/26/2021 copperwebdesign FALSE 0.00 600
9/22/2020 primewebdesign FALSE 0.00 500
9/22/2020 lighthousewebdesign TRUE 2495.00 500
2/26/2021 webdesigncorp FALSE 0.00 500
2/26/2021 webdesigner TRUE 0.00 500



LN

PATRICK'S RANK

X

Charge for Actively Entered
Date URL Available availibility PRA Rank DCA Rank in Use by
3/2/2021|industrysiteregistry TRUE 0.00 13000 100 PRA
3/2/2021 industrywebsiteregistry =~ TRUE 0.00 13000 100 PRA
3/2/2021 industrysitedesign TRUE 0.00 12000 900 PRA
3/2/2021 industrywebsitedesign TRUE 0.00 12000 900 PRA
3/2/2021 industryweblist TRUE 0.00 12000 100 PRA
3/2/2021 industrysitelist TRUE 0.00 12000 100 PRA
2/26/2021 webitesforindustry TRUE 0.00 10000 400 PRA
2/26/2021 sitesforindustry TRUE 0.00 10000 200 PRA
2/26/2021 paragonwebdesign TRUE 1330.00 10000 200 PRA
3/2/2021 industryregistry TRUE 4888.00 9000 100 PRA
2/26/2021 webdesigninc TRUE 500.00 8000 900 PRA
3/2/2021 industry2020 TRUE 0.00 8000 200 PRA
2/26/2021 copperwebsites TRUE 0.00 7000 100 PRA

1
2
3
4
5
6
7/
8
9



Date URL

3/2/2021 industrysitedesign

3/2/2021 industrywebsitedesign
2/26/2021 webdesigninc
2/26/2021 websitemanufacturing
2/26/2021 industrysites
2/23/2021 technicalwebdesign
2/26/2021 webservice
2/26/2021 copperwebdesign
9/22/2020 primewebdesign
9/22/2020 lighthousewebdesign
2/26/2021 webdesigncorp
2/26/2021 webdesigner
2/26/2021 squarewebdesign

Charge for

LN

DEBORAR'S RANK

X

Actively Entered

Available availibility PRA Rank DCA Rank in Use by

TRUE
TRUE
TRUE
TRUE
TRUE
TRUE
TRUE
FALSE
FALSE
TRUE
FALSE
TRUE
TRUE

0.00
0.00
500.00
0.00
4999.00
0.00
250000.00
0.00
0.00
2495.00
0.00
0.00
2395.00

12000
12000
8000

900
900
900
900
800
600
600
600
500
500
500
500
500

PRA
PRA
PRA
PRA
PRA
DCA
PRA
PRA
PRA
PRA
PRA
PRA
PRA




O 00~ O U1 AWM=

Date URL

2/26/2021 4industry
2/26/2021 commercialwebdesign
2/26/2021 copperdesigns
2/26/2021 copperwebdesign
2/26/2021 copperwebs
2/26/2021 copperwebsites
2/26/2021 crownindustry
2/26/2021 diamonddesign
2/26/2021 diamondsites
2/26/2021 elemental
2/26/2021 enterprisedesign
2/26/2021 goindustry

3/2/2021 homepageindustry

Charge for

LN

ALPHABETIZED

|

Actively Entered

Available availibility PRA Rank DCA Rank in Use by

TRUE
TRUE
FALSE
FALSE
FALSE
TRUE
FALSE
FALSE
FALSE
FALSE
FALSE
FALSE
TRUE

25000.00
2999.00
0.00
0.00
0.00
0.00
0.00
0.00
0.00
0.00
0.00
0.00
0.00

0
200
500
600
200
100
100
100
200
100
500
100
400

PRA
PRA
PRA
PRA
PRA
PRA
PRA
PRA
PRA
PRA
PRA
PRA
PRA




' ENTERED BY

X

Charge for Actively Entered
Date URL Available availibility PRA Rank DCA Rank in Use by
2/23/2021 technicalwebdesign TRUE 0.00 600 DCA
2/23/2021 technicalwebdesigns TRUE 0.00 400 DCA
2/23/2021 webdesignpowerify TRUE 0.00 200 DCA
2/23/2021 webpowerify TRUE 0.00 100 DCA
2/26/2021 4industry TRUE 25000.00 0 PRA
2/26/2021 commercialwebdesign TRUE 2999.00 200 PRA
2/26/2021 copperdesigns FALSE 0.00 500 PRA
2/26/2021 copperwebdesign FALSE 0.00 600 PRA
2/26/2021 copperwebs FALSE 0.00 200 PRA
2/26/2021 copperwebsites TRUE 0.00 100 PRA
2/26/2021 crownindustry FALSE 0.00 100 PRA
2/26/2021 diamonddesign FALSE 0.00 100 PRA
2/26/2021 diamondsites FALSE 0.00 200 PRA



1
2
3

4

5

6

7/

8

9

10
11
12
13

—
AN

Date URL

3/2/2021 industrysitedesign
2/26/2021 webdesigninc
2/26/2021 websitemanufacturing
2/26/2021 websitemachinery

3/2/2021 industrywebsitedesign
2/26/2021 industrysites
2/23/2021 technicalwebdesign
2/26/2021 webservice
2/26/2021 copperwebdesign
9/22/2020 primewebdesign
9/22/2020 lighthousewebdesign
2/26/2021 webdesigncorp
2/26/2021 webdesigner

Charge for

|

Actively Entered

Available availibility PRA Rank DCA Rank in Use by

TRUE
TRUE
TRUE
TRUE
TRUE
TRUE
TRUE
TRUE
FALSE
FALSE
TRUE
FALSE
TRUE

0.00
500.00
0.00
0.00
0.00
4999.00
0.00
250000.00
0.00
0.00
2495.00
0.00
0.00

12000
8000

900
900
900
400
900
800
600
600
600
500
500
500
500

PRA
PRA
PRA
PRA
PRA
PRA
DCA
PRA
PRA
PRA
PRA
PRA
PRA

LN
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STEPS TO SORT

e Make sure you have backed up and added a sequence column!
e Place the cursor on the heading of the column you want to sort.
e C(Click the Data tab, In Sort and Filter click the AZ Arrow Button.

ONLY highlight Il, not the whol I Charge for
[ )
'ghlight one cell, not the whole column. availibility| PRA Rank| DCA Rank
e You can sort ascending or descending. 0.00 12000=
e C(lick the ZA-AZ button to sort by more than column. 500.00 8000

0.00

Home Insert Pagelayout Formulas Data Review

TR YA
zl Sort Filter % 'ﬂll l
. E Advanced Z

Sort & Filter




e Placein the cell Al (upper left cell), not selecting any other cells.
e ONLY highlight one cell, not the whole column.

e C(Click the Data tab. In Sort and Filter click the filter funnel button.
e All your columns now have a down arrow.

e Date filtering is slick, it will break it down by months if you want.

Home Insert Pagelayout Formulas Data Review

TR YA

zl Sort Filter ﬂ
. Ehd\rﬂnced

Sort & Filter

STEPS TO FILTER

2 2/26/2021 webdesigninc
3 2/26/2021 websitemanufacturing
4 2/26/2021 websitemachinery

v W=

Filter



FILTERING INITIAL VIEW

X

Charge for Actively Entered

Dat. URL - Availabli- availibilit-/PRA Ran>| DCA Ran- inUse - by =
2/26/2021 webdesigninc TRUE 500.00 8000 900 PRA
2/26/2021 websitemanufacturing TRUE 0.00 900 PRA
2/26/2021 websitemachinery TRUE 0.00 400 PRA
3/2/2021 industrywebsitedesign TRUE 0.00 900 PRA
2/26/2021 industrysites TRUE 4999.00 800 PRA
2/23/2021 technicalwebdesign TRUE 0.00 600 DCA
2/26/2021 webservice TRUE 250000.00 600 PRA
2/26/2021 copperwebdesign FALSE 0.00 600 PRA
9/22/2020 primewebdesign FALSE 0.00 500 PRA
9/22/2020 lighthousewebdesign TRUE 2495.00 500 PRA
2/26/2021 webdesigncorp FALSE 0.00 500 PRA
2/26/2021 webdesigner TRUE 0.00 500 PRA
2/26/2021 squarewebdesign TRUE 2395.00 500 PRA

1
3
4
5
6
7
8
9

O 0 N O U1 B W N

e N = =
A W N R O



FILTER TO JUST DEBORAR'S
HIGHEST RANKED SITES

Just click the arrow on the column you want to use to filter.

X

Charge for Actively Entered
Dat. URL - Availabli. availibilit- PRA Ran-| DCA Ranx inUse - by -
2/26/2021 webdesigninc TRUE 500.00 8000 900 PRA

2/26/2021 websitemanufacturing TRUE 0.00 900 PRA
3/2/2021 industrywebsitedesign TRUE 0.00 12000 900 PRA
2/26/2021 industrysites TRUE 4999.00 800 PRA




’—“
ER VIEWS OF FILTERING

OT

Al ZA T{'Clear
zd |7
z| Sort | Filter & Reapply e Clear filters with one button on the “Sort and Filter” section.
A
| Y& Advanced e Select years or months.
sttt Llliss e Choose ranges for numbers and dates.
Date Filters >

e Explore numerous other options for filtering.

Search () PR e Easily turn off filtering by clicking the filtering funnel.

~1v| (Select All)

v

2021
v’ February
+[v] March
~[v12020

+ v July

+v] September

Show rows where:

Charge for availibility

is greater than or equal to ~| 2000

QO and O or

is less than or equal to
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CREATING A SEQUENCE
NUMBER COLUMN

Right click column A and click insert.

Add column heading, “Sequence#”.

PutalinRow 2 anda?2inRow 3.

Highlight the 1 and 2.

Point at the little dot in the bottom right and double click when your cursor changes to a plus sign.
Best to wait until you have several rows of data as you have to redo it.



SPEAKER SCHEDULES MEMBER LISTS WITH MAIL MERGE
(ADD THISTO SKILLS LISTS
EXAMPLE TEMPLATES.)

GIRVCRENIN

SOCIAL EVENT PUBLIC ATTENDEE LISTS
ATTENDEE LISTS, MEAL NOLFIVISNIN
CHOICES



T

WHERE TO GET TEMPLATES

URL for Templates is
hitps://arehart.com/spreadsheets

More will be added

There will be a way to sort and filter o find
templates you want


https://arehart.com/spreadsheets

Grocery/Shopping Lists

Invitation Lists

Menus for Dinner Parties, Dinners

POPULAR

.‘} Inventory
LISTS )
am Giff Lists
Passwords

Names and addresses for Book Club, Neighborhood,
Optimists, Friends




BUILDING BETTER SPREADSHEETS

« Patrick Arehart

« Centerville Noon Optimist Club

« Ohio District Webmaster 2022-2024
« pra@arehart.com 937-681-1902

« Centerville Ohio (Just South of Dayton)

‘QUESTIONS?2
! QuESTK
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